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Introduction 

Using This Guide 

The purpose of this guide is to provide users 

of ExDViewer a comprehensive instructional 

manual for ExDViewer software. New users 

of ExDViewer software should start with the 

Quick Start Guide.  For more detailed 

information, users can look at the applicable 

sections in this user guide. 

What Is the ExD Solution? 

The ExD solution enables comprehensive 

characterization of proteins and peptides.  

An ExD cell upgrade with hardware and 

software lets labs use Electron Capture 

Dissociation (ECD) to: 

 

● Fragment larger protein ions. 

● Characterize labile post-translational 

modifications (PTMs), e.g., 

phosphorylation, glycosylation. 

● Differentiate isobaric residues, e.g., 

aspartate/isoaspartate, 

leucine/isoleucine. 

● Obtain complementary sequence 

information to CID b/y-ions. 

● Learn more about disulfide-bonded 

peptides and proteins. 

What Is ExDViewer Software? 

ExDViewer rapidly processes mass 

spectrometry fragmentation data and then 

displays them in an easy-to-understand 

format with annotated spectra, sequences, 

and tables.  ExDViewer annotates all protein 

fragment ion types — b, y, c, z, a, x, including 

side chain fragmentation which 

distinguishes isobaric amino acids such as 

leucine and isoleucine. 

 

Using ExDViewer’s unique parameter-free 

deconvolution algorithm, proteins and 

peptides can be rapidly sequenced using 

evidence from raw mass spectra. In addition, 

unknown amino acids matching an 

Averagine model are highlighted in the mass 

spectrum.  Results can be shared with 

colleagues using a file or with a Uniform 

Resource Locator (URL) that can be opened 

in a web browser. 

ExDViewer Setup 

Minimum Configuration 

Hardware 

● Windows-type PC 

● Intel Core i3 CPU or equivalent 

● 4 GB Random Access Memory 

(RAM) 

● 50 GB hard disk space (more if many 

large data files will be processed) 

Software 

● Microsoft Windows 10 or higher 

operating system 

● For the web browser-based version, 

Google Chrome version 113 (or 

higher) or equivalent 

Installing ExDViewer 

1. Download the ExDViewer executable 

file. 
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2. Right-click on the file and select Run 

as administrator. 

 

 
 

3. Follow the prompts to select where 

the application will be installed and 

whether to create a Windows 

desktop icon. 

Uninstalling ExDViewer 

1. Click on the Windows Start icon in 

the lower left corner. 

2. Select the Settings item. 

3. In the Settings dialog box choose 

Apps 

4. In the Apps & features dialog box, 

click on the ExDViewer 

5. Click on the Uninstall button and 

follow the instructions: 

 

 

How to Respond to Update Messages 

Sometimes when you open ExDViewer you 

may receive an update message in the lower 

right corner.  This might notify you that: 

 

● A new version of ExDViewer is 

available. 

● The prerelease version that you are 

using will soon no longer be 

operational and that you should 

upgrade to continue using 

ExDViewer. 

● A specific issue exists that you 

should be aware of. 

 

Follow the instructions then dismiss the 

update message. 

Starting ExDViewer 

Right-click on the ExDViewer icon on the 

Windows desktop and select the Open menu 

item: 

 

 
 

The ExDViewer software program will open: 

 

 

Example Files Available with 
ExDViewer 

Downloading the Sample Data Files 

1. Select the File > Download Sample 

Data menu item.  A file will begin to 

download. 
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2. Go to the Downloads folder in the 

Windows Explorer and extract the 

zipped file which contains Agilent 

MassHunter *.d LC/Q-TOF data files: 

 

 

 
 

3. Move the data files to the normal 

place for LC/Q-TOF data files on the 

PC, e.g. \MassHunter\Data. 

4. Example data files can be analyzed 

using the Hybrid Deconvolution 

workflow described later in this 

guide. Example protein sequences 

are pre-loaded in the Target Editor for 

use with example files. 

Loading Example exdview Files 

exdview files are result files created by 

ExDViewer.  They contain annotated mass 

spectra, sequence information and coverage 

(including ion types and PTMs assigned to 

positions), tables of results, and window 

layouts.  ExDViewer lets you load several 

example exdview files which illustrate many 

of the features of the ExD solution. 

 

To load an example exdview file, either select 

View Results > Browse Examples in the 

Navigation UI or go to the File > Load 

Example Run menu item. 

 

 

 
 

Choose one of the examples, e.g., 

“Distinguish isobaric residues”, and click the 

Open button.  The example exdview file will 

begin to load; if an exdview file has a custom 

window layout saved with it you will be 

prompted whether to load it: 

 

 
 

Click “Yes”. 

 

The results will load into ExDViewer: 
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Processing Data Files Using the 
Hybrid Deconvolution Workflow 

What is the Hybrid Deconvolution 
Workflow? 

The Hybrid Deconvolution workflow answers 

the question “Does this data confirm my 

hypothesized protein or peptide?”  It clearly 

shows the evidence in the source raw data 

by highlighting the specific types of ions 

found.  These could be generated by ECD (c 

and z ions), EID (d and w ions), and CID (b 

and y ions).  In addition, a ions can be 

generated by both ECD and CID.  Finally, 

ExDViewer will annotate internal ions (which 

are fragmented on both the amino and 

carboxyl end) as well as unknown ions that 

match an Averagine model for amino acids1. 

The Signal Processing Algorithm 

ExDViewer uses a signal processing 

algorithm to measure how well each putative 

ion in a mass spectrum fits a statistical 

model.  The model has been validated 

against results from human curators2.  The 

fitting from the model calculates an Ion 

Score which assigns a value between 0 and 

15.   

 

𝐼𝑜𝑛 𝑆𝑐𝑜𝑟𝑒 =  (1.0 −  𝑐ℎ𝑖 − 𝑠𝑞𝑢𝑎𝑟𝑒𝑑 𝑝 −

𝑣𝑎𝑙𝑢𝑒)  ×  𝑆𝑝𝑒𝑎𝑟𝑚𝑎𝑛 𝑐𝑜𝑟𝑟𝑒𝑙𝑎𝑡𝑖𝑜𝑛 ×  𝑙𝑜𝑔((1.0 −

𝑃𝑒𝑎𝑟𝑠𝑜𝑛 𝑝 − 𝑣𝑎𝑙𝑢𝑒)/noise probability)                             

                                                                      

where: 

 

chi-squared p-value is based on centroid m/z 

and intensities. 

Spearman correlation is based on profile raw 

signal. 

Pearson p-value is based on centroid 

intensities. 

noise probability–assuming independence of 

centroids, what is the probability of 

observing peaks with higher intensities? This 

parameter captures peak density as a 

function of intensity rank in the wider 

spectrum. 

 

An Ion Score is classified as: 

 

● Restrictive if ≥ 3.0 

● Default if ≥ 1.5 (recommended for 

most analyses) 

● Permissive if ≥ 0.5 

 

 

“Parameter-free” Deconvolution 

Deconvolution converts complex signals in 

mass spectra into a simpler form that is 

easier to understand. In ExDViewer, a unique 

deconvolution algorithm is used to 

effectively parse isotope clusters in raw 

mass spectra. Traditionally, deconvolution 

algorithms only fit an Averagine isotope 

distribution to each putative isotopic cluster, 

allowing for fragment peak charge 

determination in an un-targeted manner. 

This is done in ExDViewer, but when 

matching to a known peptide or protein 

sequence, ExDViewer will first generate and 

match an exact isotopic distribution for each 

putative ion accounting for the specific 
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residues, post-translational modifications, 

chemical losses/additions as a result of the 

ion type (i.e., a/b/c/d/y/w/z), and hydrogen 

transfer re-arrangements. This helps 

determine the correct theoretical isotope 

distribution before determining a quality 

score of each putative ion match. ExDViewer 

is unique in its ability to render these 

deconvolution results at the level of 

individual charge states in the interactive 

profile spectrum view, which layers the 

identified ions on top of the profile spectrum, 

centroid spectrum, and the computed noise 

threshold. 

 

For example, the zoomed-in spectrum below 

of Bovine Carbonic Anhydrase’s c37 4+ ion 

shows six peaks that make up its annotated 

isotopic cluster.  The profile spectrum is 

outlined along the x axis while each peak has 

a vertical line for its centroid location.  Boxes 

around the profile and centroid apexes 

correspond to match PPM and intensity 

thresholds.  An overarching horizontal 

curved line links the theoretical values for 

each peak, visually demonstrating any 

difference from the observed values: 

 

 
 
No parameters are required to be adjusted 
and the signal processing works with default 
settings on most types of data.  A test 
evaluating over 10,000 putative ions 
assigned by ExDViewer achieved greater 
than 99% accuracy compared to 
assignments made by experts in 
benchmarking studies evaluating a range of 
protein fragmentation data.2  

  

High-quality fragment ion matches can be 
viewed in de-charged or de-isotoped spectra 
which can greatly simplify analysis.   
 
De-charging takes all charge states for an 
identified ion and collapses it down to one 
isotope distribution. For example, the c27 ion 
in thymosin has ions in the +2, +3, and +4 
charge states that during de-charging can be 
collapsed into a molecule with a 
monoisotopic mass of 3205.6409 Da.  This 
process converts the x axis from m/z to 
Mass. When switching into de-charged 
mode, profile data is omitted and all 
unmatched centroids are assumed to be 
charge 1.  
 

 

 
 
De-isotoping combines the signal intensity 

from all detected isotopes into a single 

monoisotopic peak. Measuring distance 

between deisotoped peaks is useful for 

sequence confirmation and identifying 

unknown peaks.  
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Treatment of Hydrogen Transfer 

Transfer of hydrogen is often seen in ECD3 

as well as occasionally in CID.  As a result, 

the mass of a molecule can be off by 1 or 2 

Daltons.  For specified ion types, ExDViewer 

will use an algorithm to fit all combinations 

of the -2H, -H, neutral, +H, and +2H isotope 

distributions.   

 

The algorithm allows each ion match to use 

any combination of +/-1 or +/-2 hydrogen 

transfers.  There are three possibilities 

involving no transfer dist(0), one hydrogen 

transfer dist(H), and two hydrogen transfers 

dist(2H).  For the first two possibilities, we 

know that a + b + c = 1, thus we can use 

linear algebra to determine the coefficients 

that minimize error between observed and 

expected centroid values.  Applying a single 

hydrogen transfer event (i.e., dist(+/-H)) to a 

peak distribution simply increments or 

decrements each m/z value by a 

mass(H+)/charge.  A hydrogen transfer 

arrangement is only accepted if it yields a 

score that is at least 20% better than the 

neutral species. 

 

 
 

The ion types can be specified in the Hybrid 

Deconvolution Settings dialog box in the 

Hybrid Deconvolution workflow: 

 

 
 

Placing the mouse cursor over a labeled ion 

will show its degree of hydrogen transfer.  

The information is also available in the Ion 

Candidates, Ions, and Isotopic Peaks tables. 

 

 

Reviewing ExDViewer Results 

Windows 

ExDViewer has three main windows: the 

Spectrum, the Sequence Coverage Map, and 

Tables. 
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The default mode when loading ExDViewer 

is called Light Mode.  It is possible to switch 

to Dark Mode using the View > Dark Mode 

menu item: 

 

 
 

Windows in ExDViewer can be rearranged by 

clicking on them and moving them around 

the program area.  They can also be resized 

individually by using a double-sided arrow 

that appears in the lower right corner when 

the mouse is placed on top of them: 

 

 
 

For example, this layout can be created 

which allows clicking on an ion in the 

Sequence Coverage Map and immediately 

seeing its spectrum and ion candidate 

information: 

 

 
 

The original sizes and positions can be 

restored using the View > Reset 

Preferences menu item.  

 

In addition, it is possible to zoom in and out 

the windows using the View > Zoom In and 

Zoom Out menu items.  The default zoom 

level can be restored using the View > Reset 

Zoom menu item. 

 

Using View > Layout Settings it is possible 

to configure which windows and tables are 

visible.  Clicking the New Window button will 

create an additional window where you can 

specify which view or table it contains. 

 

 
 

A custom layout can be saved with the 

exdview file using the View > Save Layout 

menu item.  Later, it can be loaded using 

View > Load Saved Layout.  These functions 

are also available as command buttons in 

the Layout Settings dialog box. 

 

Each window has three horizontal lines in the 

top left corner.  These can be used to open in 

a new window (e.g., place the Sequence 

Coverage Map in its own window), move it 
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back to the Main View, or to close it 

completely: 

 

 
 

The default set of windows, tables, sizes, 

and positions can be reloaded using the 

View > Reset Layout menu item or by 

clicking the Reset Layout button in the 

Layout Settings dialog box. 

Sequence Coverage Map 

The Sequence Coverage Map shows the 

amino acid residues in the target sequence 

as well as fragment ion evidence that was 

matched. 

 

Reviewing the KEY which shows the 

representation of the different types of ions 

in the Sequence Coverage Map: 

 

 
 

These ion types are generated by ECD, EID 

and CID fragmentation mechanisms.  ECD 

and EID are collectively referred to as ExD: 

 

 

Most residues in the Sequence Coverage 

Map are in black text; however, those that 

have a PTM such as glycosylation or 

phosphorylation are in red.  Isoaspartate (i.e., 

“D”) is in blue text.   

Peptide Example The following content 

provides example results from a 16 residue 

synthetic peptide with the sequence 

REALLYisoDELIGHTFLK. These results can 

also be viewed interactively by loading the 

example file in ExDViewer. 

Clicking on a particular ion in the Sequence 

Coverage Map will zoom into it in the 

Spectrum view: 

 

 

 

If there are multiple instances of an ion 

detected (i.e., different charge states or 

neutral losses), when you click on an ion in 

the Sequence Coverage Map it will give you a 
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menu of which (or all) to select: 

 
 

Turning on de-charge in the Spectrum 

window will collapse all charge states down 

to one selection. 

REALLYisoDELIGHTFLK contains an 

isoaspartate (the blue D) in position 7 as well 

as four leucines (L) and one isoleucine (I).  

One of the challenges of top-down analysis 

is differentiating isobaric residues such as 

aspartate/isoaspartate and 

leucine/isoleucine. 

In ExDViewer, leucine and isoleucine can be 

differentiated by identifying side chain 

fragmentation w ions. Isoaspartate is 

indicated by an isotopic cluster 57 Daltons 

greater than the c ion: 

 

 
 

In the lower right corner, the Sequence 

Coverage Map displays the percentage of 

the total sequence that is found and 

annotated: 

 

 
 

Internal ions are fragmented on both the 

amino and carboxyl end.  ExDViewer detects 

and annotates them as brown symbols next 

to the amino acid letters but does not 

include them in the total sequence coverage.  

Detection of internal ions can be configured 

in the Hybrid Deconvolution dialog box 

during the Hybrid Deconvolution workflow.  

Hovering over any ion will bring up a 

description as well as its Ion Score and Fit 

percentage (a measure of how well the 

expected ion mass peaks match the 

observed isotopic ratios.  It is calculated as 

((1 –chi-squared p-value) x 100). 

 

 
 

Right-clicking anywhere in the window will 

bring up a menu to change the format of the 

Sequence Coverage Map or save an image 

as a publication-quality graphic: 
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Spectrum Window 

The Spectrum window shows the raw mass 

peaks in the processed spectrum annotated 

with matched ions and their isotopic 

clusters. 

 

It has several user interface (UI) elements for 

transforming or filtering.  The Toolbar at the 

top has command buttons which enable 

zooming, panning as well as de-charging and 

de-isotoping the spectrum: 

 

 
 

Resume/Pause/Terminate are used while 

streaming data from an instrument (see 

“Streaming Spectra Directly From an 

Instrument.”)  They allow you to control the 

flow of data into the ExDViewer software 

program.  When not streaming, they are gray 

and inactive: 

 

 
 

Pan-left and Pan-right move the x-axis in 

either direction to allow you to browse 

through the spectrum: 

 

 
 

Increase y-axis scale and Decrease y-axis 

scale move the maximum value of the 

Intensity either upward or downward: 

 

 
 

Step zoom-in and Step zoom-out either 

reduce or increase the range of the x-axis 

and y- axis.  Each time they are clicked there 

will be an incremental change to the ranges. 

 
 

Zoom to selected ion(s) allows you to select 

one or more ions in the spectrum and then 

get a zoomed in view of its isotopic peaks.  If 

more than one ion is selected the zoomed in 

view will have axis ranges to include all of 

them. 

 

 
 

Reset zoom restores the original x and y axis 

ranges and displays all the ions, whether 

selected or not. 

 

 
 

Toggle ion density view allows the ion 

symbols to either be lined up neatly (Always 

On) or shown with all ions in their exact 

place (Always Off). Dynamic Mode 

determines the best positioning for the ion 

symbols: 
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Toggle view of peak data has several 

options. 

● Selecting the Display Monoisotopic 

check box will draw a solid vertical 

line from the monoisotopic mass of 

each isotopic cluster in the spectrum.  

The line will be the same color as the 

type of ion, e.g., blue for c ions, green 

for b ions. 

● Selecting De-charge applies an 

algorithm that rapidly consolidates 

information from different charge 

states of the same ion together and 

transforms the x axis of the 

spectrum from m/z to Mass.  This 

greatly simplifies the mass spectrum 

and aids in interpretation.  

● Selecting De-isotope collapses each 

isotopic cluster into a single mass 

peak. 

 

 

 
 

Measure distance between any two masses 

provides a means of displaying the 

difference on the x-axis between two points.   

 

 

     
 

If the user chooses “Measure centroids” it 

will on the first mouse-click snap to the 

closest ion with an annotated centroid.  The 

second mouse-click will draw a dashed 

horizontal line to the closest centroid and put 

the difference above.  If the difference is 

approximately the same as a molecular 

component such as a hydrogen atom, it will 

also note that:  

 

 
 

The Available Measurements table contains 

a set of mass offsets that can be displayed 

above the dotted line, allowing multiple 

labels at the same time using the 

Combinatoric depth feature.  Choosing 

“Measure cursor” will draw a dashed 

horizontal line between two mouse-clicks 

regardless if any centroids or ions are 

nearby. 

 

Toggle selection of visible ions will 

alternate between the currently selected ion 

and all other ions.  De-select all ions will 

remove all selection of ions 
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Occasionally it is useful to move the ion 

annotations around in the spectrum, for 

example in setting up graphics for 

publication.  Clicking on the ion name, e.g., 

c21 2+, will allow this.  Revert to default 

positioning of selected ions will move all 

annotations back to their original position. 

 

 
 

Label selected ions will add annotations to 

any ions in the spectrum that are currently 

selected (as below).  Un-label selected ions 

will remove those labels. 

 

 

                        

Show all hidden ion(s) will display any ions 

that have been hidden using the Hide 

selected ion(s) command button. 

 

 
 

Hide selected ion(s) will make the currently 

selected ions disappear. 

 

Unmatch selected ion(s) will remove the 

match information for those ions that are 

currently selected. 

 

 
 

Save image as file allows you to create a 

copy in five different formats. 

 

Copy image to clipboard makes a copy 

available in the system’s clipboard. 

 

 
 

The Legend on the right side has a summary 

of all ions found including unassigned (those 

matching an Averagine model).  Selecting an 

ion (e.g., the blue z ion symbol) will highlight 

all ions of that type in the Spectrum and 

Sequence Coverage Map. 
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While moving the cursor around the 

Spectrum window the values of the x and y 

axis (m/z and Intensity) are displayed above 

the Legend: 

 

 
 

Right-clicking in the Spectrum window brings 

up a menu: 

 

 
 

● Copy makes a copy available in the 

system’s clipboard. 

● The Y-Axis Break Scale check box 

provides a dashed horizontal line in 

the Spectrum window.  Below it is a 

scale that allows lower intensity ions 

to appear (e.g., 0 to 2.5K).  Above it 

high intensity ions are displayed (e.g. 

2.5K to 300K).  Clearing the check 

box changes the y-axis to one 

consistent scale (e.g., 0 to 300K). 

● Filter ion types provides a check box 

for each type of ion (e.g., a, b, y, z).  

Clearing the check box for an ion 

type removes it from the Spectrum 

window. 

● Toggle view of peak data provides 

all the same options as the Toggle 

view of peak data command button 

in the Spectrum window’s Toolbar. 

● Tooltip allows the user to configure if 

the tooltip comes up next to each ion 

symbol and which information is 

displayed: 

 

 
 

● Legend toggles the display of the 

Legend, whether Averagine (i.e., 

unassigned) ions show up in the 

Legend, and the font size and radius 

of symbol in the Legend. 

● Symbols toggles the display of the 

ion symbols and whether they are 

symmetric (i.e., round) or non-

symmetric and point in the direction 

of the N-terminal (a, b, c, d ions) or C-

terminal (y, w, z ions).  

● Annotation Size controls the size of 

the font of the labels on ion symbols 

(e.g., z25 2+).  It is necessary to 

zoom into a spectrum to see these 
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labels since they do not show up on a 

fully zoomed-out Spectrum window. 

● Display Measurements toggles 

display of both system and user 

generated annotations across the x-

axis.  For example, when the check 

box is cleared a system generated 

annotation such as a dashed 

horizontal line with “z–43 leucine” will 

disappear as well as any annotations 

generated using the Measure 

distance between any two masses 

command button in the Toolbar. 

● Show Axis Labels toggles display of 

the x-axis (m/z) and y-axis (Intensity) 

labels.  The values for these axes 

continue to be displayed in either 

setting. 

● E Notation changes the y-axis 

(Intensity) from standard notation 

(e.g., 200) to exponential form (e.g., 

2.0e+2).   

 

There are three ways to zoom into the 

Spectrum window: 

 

● Click the Step zoom-in command 

button in the Toolbar (described 

above). 

● Click on a location in the Spectrum 

window and drag the mouse cursor 

to another location.  When the mouse 

button is lifted, the Spectrum will 

zoom to between those two 

locations. 

● Rotate the mouse scroll wheel (if 

available) to either zoom in or out of 

the currently displayed spectrum 

area. 

 

It is always possible to return to the fully 

zoomed-out Spectrum window by clicking 

the Reset zoom command button in the 

Toolbar. 

 

There are two ways to pan through the 

Spectrum window: 

 

● Click the Pan-left and Pan-right 

command buttons in the Toolbar. 

● Click on the m/z label in the x-axis 

and move either to the left or right. 

Tables 

The Tables provide different views on the 

data including matched and unmatched 

ions, targets used, raw mass peaks, m/z 

deviation across the mass range, and 

fragmentation efficiency. 

Ion Candidates Table 

The highest level in the Ion Candidates table 

is a list of the residues in the target 

sequence.  Clicking on a > opens up the 

section to see rows containing detected 

ions.  The first column lists the matched and 

unmatched ions for each residue and allows 

you to select or clear their Matched check 

box: 

 

 
 

In the default configuration, columns to the 

right of the Matched check box contain 
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information for each ion including its:  

 

● Name is the designation of the ion 

using ion type, position, and charge 

e.g., w15 1+. 

● The Ion Score as calculated in the 

section The Signal Processing 

Algorithm. 

● RankOrder is the rank applied to this 

ion after sorting by IonScore.  If two 

ions have IonScores within 35%, then 

the tie is resolved using the 

ion_types_priority setting from the 

Hybrid Deconvolution Settings dialog 

box. 

● Spearman correlation, a component 

of the Ion Score. 

● % Fit calculated as ((1 –chi-squared 

p-value) x 100), also a component of 

the Ion Score. 

● PPM, the weighted average deviation 

from the theoretical m/z for all peaks 

in the isotopic cluster expressed in 

parts per million. 

● Total Intensity is the sum of the 

intensities for all peaks in the isotopic 

cluster. 

● % H, the percentage of single 

hydrogen transfer. 

● % 2H, the percentage of double 

hydrogen transfer. 

● # Peaks, the number of isotopic 

peaks in the cluster. 

● The Monoisotopic mass of the ion, 

i.e., the mass based on the most 

abundant stable isotopes of the 

constituent elements. 

 

Clicking on the vertical Columns command 

button to the left of the Matched column 

opens an area with check boxes that allow 

further configuration of the Ion Candidates 

table.   

 

 
 

Existing columns can be removed and new 

ones can be added including: 

 

● Real indicates if the ion is present in 

the spectrum and is a true match.  

This column can be used for 

benchmarking and human curation 

of processed data. 

● Annotation when double-clicked in 

the cell, opens a dropdown with 

explanations about why the ion was 

not matched or is not real.  You can 

select an explanation and it will be 

saved with the exdview file. 

● Type of ion i.e., a, b, c, d, i (internal), 

w, x, y, z, and # (unassigned). 

● Charge e.g., +1, +2, +3. 

● Pearson correlation, a component of 

the Ion Score. 

● SNR, the signal-to-noise ratio of the 

highest theoretical isotope. 

● corrScore, also a component of the 

Ion Score. 

● Mass is the de-charged mass of the 

ion. 

● Average is the average mass of the 

ion, i.e., the average of the isotopic 

masses weighted by the isotopic 

abundances. 
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In addition, it is possible to move columns by 

clicking and holding the left mouse button on 

the column name at the top and moving it to 

the left or right.  A cross will appear 

underneath the columns that shows the 

column being moved and its new location 

once the left mouse button is released: 

 

 
 

Columns can be sorted by clicking once on 

the column name.  The first click will sort the 

column by ascending values and a ↑ symbol 

will appear after the column name; the 

second click by descending values and a ↓ 

symbol will appear: 

 

 
 

You can remove the sorting from the column 

by clicking a third time on the column name. 

 

At the top of the Columns area there is a 

Search field.  Begin typing the name of a 

column to see if it is available: 

 

 
 

Clicking on the vertical Filters command 

button to the left of the Matched column 

opens an area that allows you to set up 

filters.  For example, you can filter by the 

parts-per-million deviation from the 

theoretical m/z in the range of -2 to +2 ppm 

and exclude ions with a higher mass error.  

Clicking the Apply button updates the Ion 

Candidates table: 

 

 
 

The Clear command button clears the 

current values out of the input fields but 

does not remove the filter from the Ion 

Candidates table.  The Reset command 

button completely removes the values and 

the filter. 
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Multiple filters can be applied at the same 

time by selecting either AND or OR within the 

currently chosen filter, or by setting up 

another filter on a column, e.g., SNR.  

Columns that have a filter applied will have a 

funnel symbol after the column name: 

 

 
 

And in the Filters area: 

 

 
 

Right-clicking on the Ion Candidates table 

brings up a menu: 

 

 
 

● Copy copies the contents of the 

currently selected cell to the 

clipboard. 

● Copy with Headers copies both the 

contents of the currently selected cell 

and its column header. 

● Export > CSV Export brings up a 

dialog box to save the current 

contents of the Ion Candidates table 

in Comma Separated Value (.csv) 

format.  Note that only columns that 

are displayed in the table will be 

exported. 

● Export > Excel Export brings up a 

dialog box to save the current 

contents of the Ion Candidates table 

in Microsoft Excel worksheet (.xlsx) 

format.  Note that only columns that 

are displayed in the table will be 

exported. 

MZID Table 

The MZID table shows information about 

target sequences that were used while 

running the Hybrid Deconvolution workflow 

from an MZID file (see the section “Running 

Targets From An MZID File”).  The columns 

contain values taken from the mzIdentML4 

file (aka MZID file) specified in the Input 

dialog box.  Double-clicking on any row in the 

MZID table will use cached data from the 

input file to quickly process that target 

sequence. The MZID table will appear after 

running an MZID file with the Hybrid 

Deconvolution workflow or loading an 

exdview file with MZID results. 

 

 

Targets Table 

The Targets table shows information about 

the target sequence and spectra analyzed: 
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The Targets table replicates information 

from the Scan Selection dialog box which is 

filled out during the setup of the Hybrid 

Deconvolution workflow.  The rows are each 

segment of the data file that has results.  

These may be distinct in terms of precursor 

and time range.  For multiple, user specified 

target sequences in the same data file each 

row may have a different name under the 

Target column because they represent a 

different molecule, e.g., apamin, melittin, 

neurotensin, etc. 

 

The columns in the Targets table are: 

 

● Target is the target peptide or protein 

used to annotate each spectrum. 

● MS Level is the MS level of all scans 

averaged together. “MS2” implies 

that quadrupole precursor isolation 

was used. “All” implies that all ions 

were fragmented without precursor 

isolation. 

● Collision Energy is the collision 

energy of the first scan in this 

retention time (RT) range. 

● Precursor is the precursor m/z of all 

scans to extract for averaging (within 

the tolerance set in the Input dialog 

box for Hybrid Deconvolution). 

● MZ Error is the difference between 

the observed precursor and the 

target’s first isotope at maximum 

charge. 

● RT Begin is the beginning retention 

time in minutes of each averaging 

window. 

● RT End is the ending retention time in 

minutes of each averaging window. 

● # Scans is the number of scans 

selected in each averaging window.  

If Average Spectrum is not selected 

in the Input dialog box this will be 1. 

● Min Charge is the minimum charge 

of MS/MS ions to match.   

● Max Charge is the maximum charge 

of MS/MS ions to match. 

 

Clicking on the three horizontal lines in a 

column gives access to the menus: 

 

 
 

● Pin Column places the column in a 

location from which it will not move 

despite moving the table around. 

○ Pin Left places the column 

on the far left of the table 

○ Pin Right places the column 

on the far right of the table 

● Autosize This Column fits the size of 

the column so all text is visible. 

● Autosize All Columns fits the size of 

all columns in the table so all text is 

visible. 

● Reset Columns restores the default 

columns, positions and sizes. 

 

Clicking the funnel symbol makes it possible 

to filter on a text string: 
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Clicking the four vertical lines brings up a set 

of check boxes to configure the columns 

shown in the Targets table: 

 

 

Ions Table 

The Ions Table lists all ions found during the 

Hybrid Deconvolution workflow.  Unlike the 

Ion Candidates table, its highest level is not a 

putatively matched Residue but individual 

ions.  Although its first column is the 

Matched column, you are also unable to 

unmatch individual ions in the table.  To do 

that, you should go to the Ion Candidates 

table and uncheck their check box. 

 

The Ions table has the same default 

columns displayed as the Ion Candidates 

table.  However, there are additional columns 

that are not displayed by default and can be 

added by clicking on the vertical Columns 

command button to the left of the Matched 

column: 

 

● Internal Base Type is the type of C-

terminal cleavage for internal ions. 

● Pos is the numeric position of the 

residue that the ion may match as 

measured from the N-terminal. 

● Residue Index is the index of the 

residue this ion is associated with. 

● Internal Residue Index is the index of 

the internal C-terminal cleavage 

residue for internal ions. 

 

Many operations in the Ions table are the 

same as the Ion Candidates table, including: 

 

● Move 

● Sort 

● Search 

● Filter 

● Copy 

● Export 

 

Also, many operations are the same as the 

Targets table using the three horizontal lines 

in a column header, including: 

 

● Pin Column 

● Autosize (this column or all columns) 

● Reset Columns 

● Filter (using the funnel symbol) 

● Configure columns (using the four 

vertical lines) 

 

Many operations are the same as the 

Isotopic Peaks table (described next) 

including: 
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● The command buttons at the top 

with the exception of not having a 

Group by Ion button (the Ions table is 

already grouped in that manner). 

● The Group by feature (when right-

clicking in the table or dragging a 

column to the Group by area above 

the Matched column). 

● The Select Column feature (when 

right-clicking in the table). 

● The ability to create Charts using the 

Chart Range menu item (available by 

right-clicking in the table). 

Isotopic Peaks Table 

The Isotopic Peaks table allows the user to 

examine the raw ion data.  Each row is a 

mass peak detected in the processed 

spectrum.  In the Ion Candidates and Ions 

tables those rows are consolidated into ions 

with charges such as w15 1+, w15 2+, w15 

3+.  In the Isotopic Peaks table an ion such 

as w15 1+ will have five rows, one for each 

peak in its isotopic cluster. Multiple columns 

are available by default or can be added.   

 

 
 

At the top are seven command buttons: 

 

● Clear All Matches changes the 

values in the Matched column to 0. 

● Add to Coverage marks all ions as 

matched, changing the values in the 

Matched column to 1. 

● Subtract changes the values in the 

Matched column to 0. 

● Group by Ion moves the Name 

column up to the Group By area, thus 

displaying the Isotopic Peaks table 

as ion groups.  Each distinct ion (e.g., 

w15) will have a section under the 

Group column that opens up when 

you click on the >.  You can turn off 

Group by Ion by clicking on the x next 

to Name above the Group row. 

● Filter Unmatched turns on a filter in 

the Matched column that displays 

only ions with a value of 1.  You can 

turn off Filter Unmatched by clicking 

the Remove Filters command button. 

● Filter Unassigned removes # ions in 

the Type column.  Type # ions are 

unassigned ions that match an 

Averagine model for an amino acid 

residue.  Note that the Type column 

is not displayed by default.  You can 

turn off Filter Unassigned by clicking 

the Remove Filters command button. 

● Remove Filters turns off all filters 

and restores the original ions 

displayed in the Isotopic Peaks table. 

 

In the default configuration, columns are 

displayed which contain information for each 

ion including:  

 

● Matched which contains a 0 or 1 

depending if it is a matched mass 

peak. 

● Residue is the amino acid in the 

target sequence that the ion 

associated with that mass peak may 

match. 

● Name is the designation of the ion 

using ion type, position, and charge 

e.g., w15 1+. 
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● Pos is the numeric position of the 

residue that the ion may match as 

measured from the N-terminal. 

● MZ is the observed m/z of the mass 

peak found in the data file by the 

Hybrid Deconvolution workflow. 

● Theo MZ is the theoretical m/z of the 

mass peak. 

● PPM is the difference between the 

observed and theoretical m/z for the 

mass peak as expressed in the ratio 

parts-per-million.  PPM = (theoretical 

m/z value - observed m/z value / 

theoretical m/z value) * 106 . 

● Intensity is the observed value of the 

spectrum’s y axis for this mass peak. 

● SNR is the signal-to-noise ratio of the 

observed intensity value. 

● Abundance is the theoretical 

abundance ratio calculated for this 

isotope. 

● % H is the percentage of single 

hydrogen transfer. 

● % 2H is the percentage of double 

hydrogen transfer. 

● r Coeff is the Pearson correlation 

coefficient, which is a component of 

the Ion Score. 

● % Fit is calculated as ((1 –chi-

squared p-value) x 100), also a 

component of the Ion Score. 

● # Peaks is the number of peaks that 

match between the observed and 

theoretical isotopes. 

● ionScore is the Ion Score as 

calculated in the section The Signal 

Processing Algorithm. 

 

Clicking on the vertical Columns command 

button to the left of the Matched column 

opens an area with check boxes that allow 

further configuration of the Isotopic Peaks 

Table: 

 

 
 

Existing columns can be removed and new 

ones can be added including: 

 

● Charge e.g., +1, +2, +3. 

● Type of ion i.e., a, b, c, d, i (internal), 

w, x, y, z, and # (unassigned). 

● N/C Pos is the position of the 

fragmentation site relative to the N-

terminal as the beginning. 

● Monoisotopic indicates a Yes or No 

depending if the mass peak is the 

monoisotopic mass for the ion, i.e., 

the mass based on the most 

abundant stable isotopes of the 

constituent elements. 

 

Many operations in the Isotopic Peaks table 

are the same as the Ion Candidates table, 

including: 

 

● Move 

● Sort 

● Search 

● Filter 
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● Copy 

● Export 

 

Also, many operations are the same as the 

Targets table using the three horizontal lines 

in a column header, including: 

 

● Pin Column 

● Autosize (this column or all columns) 

● Reset Columns 

● Filter (using the funnel symbol) 

● Configure columns (using the four 

vertical lines) 

 

 
 

The Isotopic Peaks table has some features 

that are not available in other ExDViewer 

tables: 

 

● Group by, which allows transforming 

the Isotopic Peaks table to look at 

specific sets of information.  For 

example, selecting Group by Residue 

puts every mass peak row 

associated with a particular residue 

into a group.  It is possible to create a 

group underneath the group, e.g., 

Group by Name will put each ion 

under the Residue group: 

 

 
 

There are two ways to use Group by: select it 

as a menu item underneath the three 

horizontal lines in a column header, or drag 

the column up to the Group by field 

underneath the Clear All Matches command 

button.  The Group by functionality can be 

turned off by clicking in the column header 

and selecting Un-Group by, clicking the x 

next to the column name in the Group by box 

at top or by selecting Reset Columns. 

 

● Select Column is also a menu item 

underneath the three horizontal lines 

in a column header.  It will highlight 

the current column as well as any 

other column that has a cell selected.  

It is possible to multi-select cells by 

holding down the Ctrl button and 

clicking with the mouse cursor. 

 

Right-clicking in a cell provides access to the 

Chart Range menu item. For example, by 

selecting the PPM and MZ columns (as 

above) it is possible to create a scatterplot of 

the mass error in parts-per-million (ppm) 

across the mass range: 
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Once the columns have been selected, right-

click in a cell and click on Chart Range > X Y 

(Scatter) > Scatter: 

 

 
 

It is possible to create many other types of 

charts using the data in the Isotopic Peaks 

table including bar charts, pie charts, and 

histograms. 

m/z Deviation 

The m/z Deviation tab provides a graph of 

m/z delta (i.e., mass error) vs the Theoretical 

m/z. This is useful in looking at the 

performance of the instrument that the data 

were acquired on. 

 

 

Efficiency 

The Efficiency tab displays the intensity of 

components detected during the analysis 

including the mass spec precursor, reduced 

precursor ions, ECD, EID, CID, internal, and 

unassigned ions.  The count of ion clusters 

by charge state is graphed, which can assist 

in determining optimal conditions. 

  

 

Available Measurements Table 

The Available Measurements table allows 

users to customize the set of known mass 

offsets that get used when measuring the 

distance between mass peaks in the 

Spectrum window. It is preloaded with 

common amino acids, post translational 

modifications, and chemical adducts. These 

measurements are accessed via the 

measuring tool in the Spectrum window, 

making it easy to interpret unassigned peaks 

which may not match known ion types. The 

Cominatoric depth feature enables multiple 

combinations of mass offsets, with up to 

three permutations. 

 

 
 

For example, when using the Measure 

distance between any two masses 

command button in the Spectrum window’s 

Toolbar multiple mass offsets with their m/z 

error can be suggested as the user moves 

the cursor parallel to the x axis.  This can be 

useful for de novo sequencing when the 

target sequence is not unambiguously 

known. 
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There are five command buttons at the top 

of the Available Measurements table (four 

are shown here): 

 

 
 

● Load XML (BioConfirm Format) 

opens a dialog box that filters for 

XML files.  Users with Agilent 

MassHunter BioConfirm installed can 

provide an updated set of identified 

mass offsets from the BioConfirm 

XML file available at 

D:\MassHunter\ChemicalDataDiction

ary\preset\10.0\datadictionarypreset

_peptide.xml. 

● Add New Annotation creates a new 

row at the top of the Available 

Measurements table.  Users can fill in 

the information about the custom 

annotation in the columns. 

● Remove Selected deletes those 

annotations that have the check box 

in the first column checked.   

● Regenerate Combinations quickly 

calculates the use of multiple mass 

offsets together, either two or three 

at a time. 

● Reset to Defaults changes the table 

back to an initial state. 

 

The Combinatoric depth radio button allows 

you to select either 2 or 3 annotations 

applied.  Next to the radio buttons it will 

display the number of measurement labels 

that are available. 

Setting up Target Sequences with 
Target Editor 

The Target Editor enables the user to add, 

modify and curate target sequences used in 

the Hybrid Deconvolution workflow.  To 

access it, click the Target Editor icon in the 

home page Navigation UI or the File > Target 

Editor menu item. 

 

 
 

To add a target sequence, click the Add 

Target button below.  A new row will be 

created at the top with the dummy sequence 

name “target name.”  Fill this field in with 

your sequence name.  Double-click in the 

Sequence field to enter your new amino acid 

sequence.  The monoisotopic weight will 

automatically be calculated. 

 

 
 

To edit a sequence, double-click in its Target 

name and/or Sequence field.  It is also 

possible to edit the Min Charge and Max 

Charge fields to values appropriate for the 

molecule.  When you are finished, press the 

Enter key to save the new information. 

 

To delete a target sequence, select the check 

box next to its Target name and click the 

Delete Selected button.  It is also possible to 

import and export target sequences as 

JSON files, a text-based format for 

exchanging information.  This capability can 

be useful when working with collaborators 
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and reviewers.  Click the Export targets 

button to write out a JSON file to the PC’s 

hard drive.  Click the Import targets button 

to bring in target sequences using a JSON 

file accessible to the PC.  If any of the 

targets already exist in ExDViewer you will be 

prompted as to whether to keep the existing 

versions or overwrite with those from the 

JSON file. 

 

To add PTMs to target sequences, 

ExDViewer uses a derivative of Unimod 

syntax.  To access a summary, click the 

Show Target Editor Rules button in the 

upper right corner.  For example, a serine (S) 

residue that has a phosphorylation PTM will 

be annotated with (Phospho) as below: 

 

 
 

To exit the Target Editor, click the X in the 

upper right corner. 

Running the Hybrid Deconvolution 
Workflow 

The Hybrid Deconvolution workflow makes 

top-down analysis of a protein or peptide 

fast and easy.  It answers the question “Does 

this spectrum match this protein or peptide?”  

The default set of preferences can be used 

to analyze a wide variety of proteins and 

peptides. 

 

To begin the Hybrid Deconvolution workflow, 

click the Hybrid Deconvolution icon in the 

home page navigation UI or the Workflow > 

Hybrid Deconvolution menu item. 

Hybrid Deconvolution Step 1 – Input 
Dialog Box 

The Input dialog box allows you to select the 

data file or spectra to analyze as well as its 

target sequence.  In the Input File field you 

can select the type of file using the buttons.  

Note that Agilent MassHunter *.d, Thermo, 

Waters, mzML and MGF formats are 

supported. 

 

 
 

The optional De-charged Output field can be 

used to write out the deconvolution results.  

Enter a file name in and append an 

extension, i.e. .mzML, .mzXML, or .mgf.  The 

type of output file will depend on the 

extension. 

 

In the Target field use the dropdown to 

select the target sequence.  All target 

sequences available in the Target Editor will 

show here. 

 

 
 

Choose whether the spectra should be 

Averaged, and with MS1 or MS2 data. 

Automatic binning also allows you to set an 

https://www.unimod.org/unimod_help.html
https://www.unimod.org/unimod_help.html
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RT tolerance and Precursor m/z tolerance 

for the bins. 

 

In addition, select the preferred Ion 

Identification Quality as Restrictive, Default, 

or Permissive.  It is also possible to generate 

internal fragments, neutral losses, and 

common precursor adducts. 

 

 
 

Leave the rest of the preferences as their 

default values. Click the Next button. 

Hybrid Deconvolution Step 2 – Scan 
Selection Dialog Box 

The Scan Selection dialog box allows you to 

select which spectra should be processed.  

The Precursor m/z has been selected based 

on the target sequence.  When the MZ Error 

is green, it indicates that the precursor MZ 

error is within specification.  If the MZ Error 

is red, click the Estimate Max Charge check 

box. This may find a precursor maximum 

charge that is a better fit for the 

experimental spectrum.  At a later point you 

can update the Max Charge field for that 

target sequence in the Target Editor. 

 

Below, the Chromatogram window is 

interactive; you can zoom in or out and 

sliders at each end allow you to select the 

range of scans for analysis 

 

Click the Next button. 

Hybrid Deconvolution Step 3 – Peak 
Picking Dialog Box 

The Peak Picking dialog box controls the 

selection of centroid peaks from the profile 

data.   

 

Most applications can use default values for 

peak picking.  Clicking the Show advanced 

settings check box greatly expands the 

number of settings available.  After initial 

analysis, it is possible to return to this dialog 

box if adjustments are needed for settings 

such as signal to noise ratio. 

 

 
 

Click the Next button. 

Hybrid Deconvolution Step 4 – Hybrid 
Deconvolution Settings Dialog Box 

Like the Peak Picking dialog box, most 

applications can use default match setting 

values.  The values in yellow are locked to 

preset matching settings.  Removing the 

check mark from the Apply matching presets 
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preferences check box will allow them to be 

modified. 

 

 
 

When finished, click the Run Now button to 

begin the analysis. 

Running Targets from an MZID File 

It is possible to use an mzIdentML file (aka 

MZID file) as a source of targets.  To do this, 

enter an input file used to create the MZID 

file and select From MZID file under the 

Target dropdown in the Input dialog box: 

 

 
 

 In the Scan Selection dialog box click the 

check box for the target sequences of 

interest: 

 

 
 

The first target sequence will be processed 

and appear in the Spectrum, Sequence 

Coverage Map and Targets table.  Double-

clicking on any other row in the MZID table 

will use cached data from the input file to 

quickly process the next target sequence: 

 

 

Running Multiple, User Specified 
Targets 

Another option within ExDViewer is to run 

multiple target sequences at the same time.  

To do this, enter an input file with a mixture 

of compounds and select Multiple, User 

Specified under the Target dropdown in the 

Input dialog box: 

 

 
 

In the Scan Selection dialog box click the 

check box for the valid Precursor and RT 

combinations for each target sequence: 

 

 
 

The first target sequence will be processed 

and appear in the Spectrum, Sequence 

Coverage Map and Targets table.  Double-

clicking on any other row in the Targets table 

will use cached data from the input file to 

quickly process the next target sequence: 
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Running the Untargeted 
Deconvolution Workflow 

The Untargeted Deconvolution workflow 

finds all ion fragments in a spectrum or set 

of spectra that match an Averagine model 

for amino acid residues.  The ions are 

labeled as unassigned and annotated in the 

spectra.  The unassigned peptide ions can 

then be used for de novo sequencing. 

 

To begin the Untargeted Deconvolution 

workflow, click the Untargeted 

Deconvolution icon in the Navigation UI or 

select the Workflow > Untargeted 

Deconvolution menu item.  The Input dialog 

box will appear: 

 

 
  

 

Similar to the Hybrid Deconvolution 

workflow, choose an input file and settings.  

It is possible to create a De-charged Output 

file in mzML, mzXML or MGF format for 

moving results to another software program.  

 

The Untargeted Deconvolution can also be a 

form of batch deconvolution by processing 

every spectrum in the data file. 

The next three steps after Input are a subset 

of the Hybrid Deconvolution workflow with 

the same settings and options. 

Reviewing History and Loading 
Cached Runs 

 

ExDViewer has a history feature which 

allows you to examine previous runs.  To 

access it, click the History icon in the 

Navigation UI or select the File > History 

menu item.  The History dialog will appear: 

 

 
 

The processed target sequences are listed 

with the most recent at top.  Each run has 

cached an associated exdview file.  To load a 

cached run, double-click in its row.  Once it 

has loaded, close the dialog box by clicking 

the X in the upper right corner.  It is also 

possible to remove a processed target 

sequence by clicking its check box to the left 

of the Target column and clicking the 

Remove Selected button.  You might want 

to do this to save space on your PC’s hard 

drive. 

 

The Cache limit is displayed at the top as 

well as the current Cache size.  The Cache 

limit can be adjusted by clicking the Edit 

button. 
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Saving Runs as exdview Files 

ExDViewer allows you to save your 

processed runs as exdview files.  These can 

then be loaded at a later time or shared with 

another ExDViewer user.   

 

● To save an exdview file the first time, 

select the File > Save Run As menu 

item.  It is also possible to save the 

exdview file with a custom layout 

using the File > Save Run As With 

Layout menu item. 

● To update an exdview file which you 

have loaded, select the File > Save 

Run menu item (this will be 

unavailable until you have an exdview 

loaded). 

● To load an exdview file, either click 

the View Results > Select View File 

icon in the Navigation UI or select the 

File > Load Saved Run menu item.   

 

 
 

Streaming Spectra Directly From 
an Instrument 

Streaming ExD Cell Spectra From an 
Agilent LC/Q-TOF 

Streaming allows you to collect data in real 

time and view it in ExDViewer.  You can use 

streaming to optimize your acquisition 

parameters while watching the changes in 

the output.  To run streaming on an Agilent 

LC/Q-TOF with an ExD cell installed, follow 

these steps: 

 

1. Begin acquiring data from a sample 

on the instrument in MassHunter 

software’s Tune context. 

2. Click the Hybrid Deconvolution icon 

in the Navigation UI or the Workflow 

> Hybrid Deconvolution menu item. 

3. Click the Stream spectrum from 

instrument check box in the Input 

dialog box. 

4. Enter or confirm the instrument’s IP 

address in the IP Address field as 

well as the A Value and T0 Value 

(which are available in the most 

recent tune report).  Alternatively, 

click the Auto detect calibration 

parameters check box to have 

ExDViewer obtain them from the 

MassHunter software. 

5. Enter a name for the output file in the 

Output File field.  This will be saved 

to the computer’s hard drive as an 

mzML file. 

6. Enter a value in the Averaging 

Window field.  This will specify the 

number of scans averaged before the 

data is analyzed and displayed.  A 
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lower number allows faster updating 

but possibly less accuracy. 

7. Select a target sequence in the 

Target field. 

8. Set up all other preferences in the 

Input dialog box as you would for 

processing an acquired data file. 

9. In most cases, the settings in the 

Peak Picking and Hybrid 

Deconvolution Settings dialog boxes 

can remain unchanged unless you 

identify a specific reason to adjust 

them. 

10. Click the Run Now button. 

 

 
 

You will see the data from the sample 

appear in the ExDViewer as it is acquired by 

the instrument.   The spectrum will be 

updated every few seconds.  The time 

interval depends on the number of scans 

averaged, how complex the sample is, and 

the specific preferences that have been set.  

 

The constant updating allows the user to 

optimize results for specific ion types 

including all those generated by ExD or CID. 

In addition, it is possible to adjust 

fragmentation conditions on the mass 

spectrometer to achieve optimal sequence 

coverage.  All features in ExDViewer can be 

used in real time including zooming in the 

Spectrum window and clicking on ions in the 

Sequence Coverage Map.  The Fragment 

Intensity graph in the Efficiency tab will 

continuously update with percentages of 

each ion type. 

 

When you want to stop streaming, select the 

Workflow > Hybrid Deconvolution menu 

item and click the Terminate button in the 

upper right corner. 

Converting Spectra to Other 
Formats 

ExDViewer enables you to convert data files 

and spectra to other industry standard 

formats.  For input, Agilent MassHunter *.d, 

Thermo, Waters, mzML5 and MGF6 formats 

are supported.  They can be converted to 

mzML, mzXML7, and MGF files. 

 

To convert data files and spectra: 

 

1. Click the Convert icon in the 

ExDViewer Navigation UI or the 

Workflow > Convert Spectrum menu 

item. 

2. Select a data or text file in the Input 

File field using the buttons next to it.  

It is also possible to enter a spectrum 

manually by clicking the Enter 

spectrum manually check box and 

entering it in a text format.  Follow 

the instructions in the field that 

appears for the supported formats. 

3. Enter a file name in the Output File 

field and append an extension, i.e.. 

mzML, .mzXML, or .mgf.  The type of 

output file will depend on the 

extension. 

4. Select the Output data file type, either 

profile or centroid. 
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5. Choose whether the spectra should 

be Averaged, and with MS1 or MS2 

data. Automatic binning also allows 

you to set an RT tolerance and 

Precursor m/z tolerance for the bins. 

6. Set other options in the Input Files 

dialog box and click the Next button. 

7. In most cases, the settings in the 

Convert Options dialog box can 

remain unchanged unless you 

identify a specific reason to adjust 

them. 

8. Click the Run Now button. 

 

The data file or spectra will be converted to 

the selected format and placed on the file 

system in the location in the Output File field. 

Running the Browser-based 
ExDViewer 

The browser-based version of ExDViewer is 

available at the URL https://viewer.e-

msion.com/ The browser-based version has 

most of the same menu items and 

capabilities as the desktop version.   

 

 

 
 

The browser-based version does not allow 

you to upload data files at this time.  As a 

result, the following capabilities are not 

available: 

 

● Running the Hybrid Deconvolution 

workflow on a data file that is not on 

the server (i.e., a data file on your 

hard disk) 

● Running the Convert workflow 

 

The browser-based version can be used to 

share results with users who do not have 

ExDViewer installed on their PC, as described 

in the section Sharing Results using a URL.  

It can also be used to view an exdview file on 

your hard disk. 

 

The first time you open up the browser-

based version it will offer you the option of 

downloading and installing the program on 

your hard drive.  This hard drive-based 

version has the same restrictions as the 

version that runs in a browser.   

 

 

Sharing and Exporting Results 

Sharing Results Using a URL 

ExDViewer allows you to share results with 

users who do not have the software program 

installed.  This allows you to collaborate with 

others as soon as you have processed your 

data.  To share your results using a Uniform 

Resource Locator (URL) aka a web address: 

 

https://viewer.e-msion.com/
https://viewer.e-msion.com/
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1. Run the Hybrid Deconvolution, 

Untargeted Deconvolution workflow 

or load a saved run (i.e. an exdview 

file). 

2. Select the File > Share Run menu 

item. 

3. A message will appear letting you 

know that the results will be 

uploaded to a private server.  Click 

the Share button. 

4. The results will upload and then a 

message will appear with a URL.  The 

URL is also copied to your Windows 

clipboard.  Click the Close button. 

5. Copy the URL into a message that 

you can send to a collaborator.  They 

will be able to click on the URL and 

open up your results in the browser-

based ExDViewer.  They can examine 

the results including clicking on 

individual ions to inspect them. 

Exporting Results to Excel 

There are several ways to export your results 

and settings to Microsoft Excel.  

 

● The File > Export ion state as CSV 

menu item creates a Comma 

Separated Value file with a column 

for each ion’s parameter such as 

charge or molecular composition.  

The CSV file will be saved wherever 

you choose and can be opened in 

Microsoft Excel. 

● The Ion Candidates, Ions, and 

Isotopic Peaks tables allow you to 

right-click and select the Export > 

CSV Export and Excel Export menu 

items.  These files will also be saved 

wherever you choose.  Note that Ion 

Candidates and Ions will export at 

the complete ion level and Isotopic 

Peaks will export all isotopic peaks.  

Unlike the ion state export, only 

columns visible in the tables will be 

exported. 

● The Available Measurements table 

will also allow you to right-click and 

select the Export > CSV Export and 

Excel Export menu items. 
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